aboutsummaryrefslogtreecommitdiffstats
path: root/python2-numpydoc [disowned]
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2016-03-09 17:44:17 +0100
committerMattias Andrée <maandree@kth.se>2016-03-09 17:44:17 +0100
commitceaf2c7950ebd792ca569ad538f126ff2aaa617a (patch)
treebfc840f8d1d23dd4a893776b59a1b9017370626f /python2-numpydoc [disowned]
parentupdate python2-numpydoc (diff)
downloadaur-packages-ceaf2c7950ebd792ca569ad538f126ff2aaa617a.tar.gz
aur-packages-ceaf2c7950ebd792ca569ad538f126ff2aaa617a.tar.bz2
aur-packages-ceaf2c7950ebd792ca569ad538f126ff2aaa617a.tar.xz
disowning python2-numpydoc
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'python2-numpydoc [disowned]')
-rw-r--r--python2-numpydoc [disowned]/PKGBUILD28
l---------python2-numpydoc [disowned]/upload1
-rwxr-xr-xpython2-numpydoc [disowned]/watch20
3 files changed, 49 insertions, 0 deletions
diff --git a/python2-numpydoc [disowned]/PKGBUILD b/python2-numpydoc [disowned]/PKGBUILD
new file mode 100644
index 0000000..311df58
--- /dev/null
+++ b/python2-numpydoc [disowned]/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Previous maintainer: Elena ``of Valhalla'' Grandi <elena.valhalla@gmail.com>
+
+pkgname=python2-numpydoc
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Sphinx extension to support docstrings in Numpy format"
+arch=('any')
+url="https://github.com/numpy/numpy/tree/master/doc"
+license=('BSD')
+depends=('python2' 'python2-sphinx')
+backup=()
+options=(!emptydirs)
+install=
+source=(http://pypi.python.org/packages/source/n/numpydoc/numpydoc-$pkgver.tar.gz)
+md5sums=('5f1763c44e613850d56ba1b1cf1cb146')
+
+package() {
+
+ cd "$srcdir/numpydoc-$pkgver"
+
+ python2 setup.py install --root=$pkgdir/ --optimize=1 || return 1
+
+ install -D -m644 "$srcdir/numpydoc-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ chmod 644 "$pkgdir"/usr/lib/python*/site-packages/numpydoc-$pkgver-py*.egg-info/*
+
+}
diff --git a/python2-numpydoc [disowned]/upload b/python2-numpydoc [disowned]/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/python2-numpydoc [disowned]/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file
diff --git a/python2-numpydoc [disowned]/watch b/python2-numpydoc [disowned]/watch
new file mode 100755
index 0000000..d51351b
--- /dev/null
+++ b/python2-numpydoc [disowned]/watch
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+[ -f 'index.html' ] && rm 'index.html'
+wget https://pypi.python.org/pypi/numpydoc >/dev/null 2>/dev/null
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ grep numpydoc- < index.html | md5sum > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'python2-numpydoc'
+ fi
+ rm index.html
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'python2-numpydoc (unfetchable)'
+fi
+